[Biopython-dev] [Bug 2480] Local BLAST fails: Spaces in Windows file-path values

bugzilla-daemon at portal.open-bio.org bugzilla-daemon at portal.open-bio.org
Mon May 19 21:03:44 UTC 2008


------- Comment #13 from drpatnaik at yahoo.com  2008-05-19 17:03 EST -------
To get BioPython call BLAST, this works:
  1. my_blast_exe = r'"C:/Documents and Settings/patnaik/My

Variations like these do not work:
  2. "C:/Documents and Settings/patnaik/My Documents/blast/bin/blastall.exe"
  3. r"C:/Documents and Settings/patnaik/My Documents/blast/bin/blastall.exe"

The error being:
  'C:/Documents' is not recognized as an internal or external command, operable
program or batch file.

With my_blast_exe set to the 1st value constant, and trying different
my_blast_db values, BLAST reports:
  [NULL_Caption] ERROR: Arguments must start with '-' (the offending argument
#5 was: 'and') /* or 'and\' or 'and\\' */

The values tried for my_blast_db are:
  4. 'C:/Documents and Settings/patnaik/My Documents/blast/bin/mine'
  5. 'C:/Documents\ and\ Settings/patnaik/My\ Documents/blast/bin/mine'
  6. 'C:/Documents\\ and\ Settings/patnaik/My\\ Documents/blast/bin/mine'

  7. "C:/Documents and Settings/patnaik/My Documents/blast/bin/mine"
  8. "C:/Documents\ and\ Settings/patnaik/My\ Documents/blast/bin/mine"
  9. "C:/Documents\\ and\\ Settings/patnaik/My\\ Documents/blast/bin/mine"

  10. r'C:/Documents and Settings/patnaik/My Documents/blast/bin/mine'
  11. r'C:/Documents\ and\ Settings/patnaik/My\ Documents/blast/bin/mine'
  12. r'C:/Documents\\ and\\ Settings/patnaik/My\\ Documents/blast/bin/mine'

  13. r"C:/Documents and Settings/patnaik/My Documents/blast/bin/mine"
  14. r"C:/Documents\ and\ Settings/patnaik/My\ Documents/blast/bin/mine"
  15. r"C:/Documents\\ and\\ Settings/patnaik/My\\ Documents/blast/bin/mine"

But a different error ...:
  'C:/Documents' is not recognized as an internal or external command, operable
program or batch file.

... is shown with these values:

  16. r'"C:/Documents and Settings/patnaik/My Documents/blast/bin/mine"'
  17. r'"C:/Documents\ and\ Settings/patnaik/My\ Documents/blast/bin/mine"'
  18. r'"C:/Documents\\ and\\ Settings/patnaik/My\\ Documents/blast/bin/mine"'

That same error is also seen when I try these variations of the value that
works in command-line BLAST (comment #10 above):

  19. r'\"C:\Documents and Settings\patnaik\My Documents\blast\bin\mine\"'
  20. r'"\"C:\Documents and Settings\patnaik\My Documents\blast\bin\mine\""'
  20. "\"C:\Documents and Settings\patnaik\My Documents\blast\bin\mine\""
  21. r"\"\"C:\Documents and Settings\patnaik\My Documents\blast\bin\mine\"\""
  22. r"'\"C:\Documents and Settings\patnaik\My Documents\blast\bin\mine\"'"

Doesn't this suggest that Biopython is not passing the my_blast_db value

Configure bugmail: http://bugzilla.open-bio.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the Biopython-dev mailing list