[Biopython-dev] TravisCI BioSQL - TypeError: unhashable type: 'bytearray'

Chris Mitchell chris.mit7 at gmail.com
Thu Oct 9 23:18:41 UTC 2014

Also for a fix, i haven't tried this yet but my guess is the
mysql-connector-python update is returning bytearrays (maybe a python3
move?). So we need to wrap the cursor for each result. Currently, we check
if each element is of type bytes, which is an str but a bytearray is an
array of ints. So we should be doing something like if isinstance(xxx[],
(bytes, int)): xxx[0].decode('utf-8')

Sent from my phone.
On Oct 9, 2014 6:04 PM, "Peter Cock" <p.j.a.cock at googlemail.com> wrote:

> On Thu, Oct 9, 2014 at 6:27 PM, Chris Mitchell <chris.mit7 at gmail.com>
> wrote:
> > Have you tried specifying the working version of mysql-connector-python
> with
> > pip?
> >
> > ie. pip install mysql-connector-python==xxx
> No, but that might be nicer in the short term than simply skipping
> installing and testing with mysql-connector-python on TravisCI.
> https://github.com/biopython/biopython/commit/4d54e46549df2a6cfc9815af38066ede1ce7f280
> https://github.com/biopython/biopython/issues/370
> Anyone can fork Biopython, enable TravisCI on your fork, and
> then try modifying the .travis.yml file to test this... ;)
> Peter
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.open-bio.org/pipermail/biopython-dev/attachments/20141009/02d04c08/attachment.html>

More information about the Biopython-dev mailing list