[Biopython-dev] Travis-CI failing due to t-coffee dependency

Fields, Christopher J cjfields at illinois.edu
Sun Aug 3 19:52:19 UTC 2014

Can you run cpanm to install those? I think that's what we do for bioperl.


Sent from a Phone of Ingenuity (+3)

-------- Original message --------
From: Eric Talevich
Date:08/03/2014 11:46 AM (GMT-06:00)
To: Evan Parker
Cc: BioPython-Dev Mailing List
Subject: Re: [Biopython-dev] Travis-CI failing due to t-coffee dependency

On Sat, Aug 2, 2014 at 9:56 PM, Evan Parker <eparker05 at gmail.com<mailto:eparker05 at gmail.com>> wrote:
Hey Biopython-Dev,

I was pushing some commits today and I noticed failures on Travis-CI due to dependency failures. Travis was giving me the following error:
* > The command "sudo apt-get install t-coffee
*  muscle mafft probcons wise emboss" failed
*  and exited with 100 during .
I have a link to the error below. I broke apart the dependencies and tried again and I identified t-coffee as the issue. I'm not exactly sure of how to proceed from this point or if others have experienced this or are currently experiencing this.

A Travis-CI job that failed due to this error:

My latest feature-branch commit that identified the specific Travis-CI dependency failure

-Evan Parker

It looks like this affected all 5 builds on the two commits before your fix (beginning within the last day), so I suppose it's not just a transient network error on Travis's side?

The apt-get failure is for only one package in the main Ubuntu US repository, libxml-sax-perl, which is a dependency of libxml-simple-perl<http://packages.ubuntu.com/precise/libxml-simple-perl> which t-coffee "recommends":

What if we tried adding the "--no-install-recommends" flag to the Travis configuration?
"sudo apt-get install --no-install-recommends t-coffee"

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.open-bio.org/pipermail/biopython-dev/attachments/20140803/13a72888/attachment.html>

More information about the Biopython-dev mailing list