[Biopython-dev] setuptools breaking biopython-1.62b installation

Peter Cock p.j.a.cock at googlemail.com
Wed Jul 24 09:26:12 UTC 2013

On Wed, Jul 24, 2013 at 8:31 AM, Michiel de Hoon <mjldehoon at yahoo.com> wrote:
> Dear all,
> When trying to install Biopython on a new MacBook, I get the following error message when I run "python setup.py build":
> tkx330:biopython-1.62b mdehoon$ python setup.py build
> Traceback (most recent call last):
>   File "setup.py", line 109, in <module>
>     from setuptools import setup, Command
>   File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/distribute-0.6.45-py2.7.egg/setuptools/__init__.py", line 2, in <module>
>     from setuptools.extension import Extension, Library
> ...
>   File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/distribute-0.6.45-py2.7.egg/pkg_resources.py", line 1211, in get_metadata
>     return self._get(self._fn(self.egg_info,name))
>   File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/distribute-0.6.45-py2.7.egg/pkg_resources.py", line 1326, in _get
>     stream = open(path, 'rb')
> IOError: [Errno 13] Permission denied: '/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/python_dateutil-2.1-py2.7.egg/EGG-INFO/top_level.txt'
> This looks like a simple problem with file permissions, and I hope can be solved easily.

My guess would be there is something broken with your dateutil install,
a little Google searching shows very similar issues with other packages.

> Still, it is quite discouraging to first-time users of Biopython.

Yes, but I'm not sure it is our fault :(

> Do we actually need setuptools?
> Looking at setup.py, it seems that distutils is sufficient for our needs.
> If so, let's remove the dependency on setuptools.

I will have to pass that question to Brad,


More information about the Biopython-dev mailing list