[Biopython-dev] 2/23 biopython Questions - BioStar

Feed My Inbox updates at feedmyinbox.com
Wed Feb 23 09:26:36 UTC 2011

// MuscleCommandline not writing file
// February 22, 2011 at 2:34 PM

I'm trying to work through the Biopython tutorial on multiple sequence alignment and get an error whenever I try to use subprocess:

child = subprocess.Popen(str(cline),
         stdout = subprocess.PIPE,
         stderr = subprocess.PIPE,
         shell = (sys.platform!="win32"))

I get this error:

    Traceback (most recent call last):
  File "<pyshell#36>", line 2, in <module>
    stdout = subprocess.PIPE)
  File "C:\Python27\lib\subprocess.py", line 672, in __init__
    errread, errwrite)
  File "C:\Python27\lib\subprocess.py", line 882, in _execute_child
WindowsError: [Error 2] The system cannot find the file specified

I've gone so far as to copy and paste the tutorial into the interpreter and no luck. Neither ClustalW nor Muscle are writing the alignment files (I tried the depreciated MultipleAlignCL as well with no luck).

I'm using Python v2.7 and Biopython v1.55 and have tried reinstalling both. Any advice?

Website: http://biostar.stackexchange.com/questions/tagged/biopython

Account Login: 

Unsubscribe here: 

This email was carefully delivered by FeedMyInbox.com. 
PO Box 682532 Franklin, TN 37068

More information about the Biopython-dev mailing list