[Fwd: Re: [Biopython-dev] Bio.CAPS module submission]
Jonathan Taylor
jonathan.taylor at utoronto.ca
Wed Feb 16 15:57:46 EST 2005
I chose suite() because in the pyunit documentation they say its a good
idea to include such a callable object (read method) named suite.
http://pyunit.sourceforge.net/pyunit.html#SUITES
From the page:
--- SNIP ---
For the ease of running tests, as we will see later, it is a good idea
to provide in each test module a 'callable' object that returns a
pre-built test suite:
def suite():
suite = unittest.TestSuite()
suite.addTest(WidgetTestCase("testDefaultSize"))
suite.addTest(WidgetTestCase("testResize"))
return suite
--- SNIP ---
Cheers.
Jon.
Michael Hoffman wrote:
> On Wed, 16 Feb 2005, Iddo Friedberg wrote:
>
>> Jonathan Taylor floated an idea to add unit testing in addition to
>> regression testing. Seems useful, and the change to setup.py is minor.
>> There should be no changes to the test_MODULE.py files, or the current
>> behavior of run_tests.py
>>
>> Does anybody see any problem with this? I don't.
>
>
> Sure, except I think "suite" as a name doesn't really explain very
> much and I hate to get stuck with it.
>
> I have used doctests before but just wrapped them in the existing
> regression testing framework. See test_GFF. In general, Jonathan's
> method is superior.
More information about the Biopython-dev
mailing list