[Bioperl-l] bioperl on CentOS 6.4

Fields, Christopher J cjfields at illinois.edu
Tue Nov 19 22:55:29 UTC 2013

On Nov 19, 2013, at 4:12 PM, m.roth at 5-cent.us wrote:

> Fields, Christopher J wrote:
>> On Nov 19, 2013, at 3:07 PM, m.roth at 5-cent.us wrote:
>>> If there is such info, I'd very much appreciate a link to how to install
>>> BioPerl on CentOS 6.4 (which is the same as RHEL 6.4, or, I think,
>>> Scientific Linux 6.4....)
>>> Currently, a) cpan fails to install; b) the "current" version won't
>>> build due to dependencies on some newer libraries, and c) 9.0.1 is a
> nightmare
>>> of dependencies, which I had to patch to change all references to
>>> /usr/bin/perl from /bin/ perl and /usr/bin/perl, and, among many other
>>> requirements to install, though not to build, is Ace, which I see
>>> deprecated in the Build.PL, but used in several modules.
>> We need a bit more information, in particular how you are trying to
>> install the software, what is actually failing test-wise, etc.  The latest
>> version on CPAN is v1.6.922, so I’m not sure what version 9.0.1 refers to.
>> You do not need Ace; it is a ‘recommended’ module but is not required; we
>> will likely deprecate or remove the Ace-related modules at some point.
>> The latest CPAN Testers output indicates that most failing tests are on
>> Windows systems (no real surprise there).  A few Linux installs seems to
>> have failures as well, so if this leads to better tests or having things
>> pass on more OS’s, all the better.
> Sorry, I have 1.6.901. When I tried to build the current, it failed, as I
> said, because it wanted newer libraries (it's been a few weeks since I
> tried to build that, gave up, and went to what I found as the "previous"
> released version).

I would try the latest on CPAN to see if that helps:


> I understand Ace is deprecated, but I have files that were in the .tgz
> that say "use Ace;". And after I build it, and use rpmerizor (we figure if
> we get it working, they'll want it on other servers), and try to install,
> it fails to install with the following requirements:

Ah, then that explains it.  RPM builders don’t differentiate between ‘recommended’ and ‘required’ modules.  

>           Requires: perl(Bio::Tools::Run::Samtools)
>           Requires: perl(Bio::Phylo::Matrices::Matrix)
>           Requires: perl(Bio::Tools::Run::Phylo::Phylip::ProtPars)
>           Requires: perl(Bio::Tools::Run::Primer3)
>           Requires: perl(Bio::Expression::Sample)
>           Requires: perl(Bio::Phylo::Forest::Tree)
>           Requires: perl(enum)
>           Requires: perl(Bio::Phylo::Matrices::Datum)
>           Requires: perl(Ace)
>           Requires: perl(Bio::Expression::Platform)
>           Requires: perl(Bio::Factory::EMBOSS)
>           Requires: perl(Bio::Expression::Contact)
>           Requires: perl(Bio::Graphics::Panel)
>           Requires: perl(Bio::Tools::Run::Alignment::Clustalw)
>           Requires: perl(Bio::Tools::BPlite)
>           Requires: perl(Bio::Expression::DataSet)
>           Requires: perl(Bio::Phylo::IO)
>           Requires: perl(Bio::ASN1::EntrezGene)
>           Requires: perl(Bio::Tools::Run::Phylo::Phylip::Neighbor)
>           Requires: perl(Bio::Phylo::Factory)
>           Requires: perl(Bio::Tools::Run::Phylo::Phylip::ProtDist)
>           Requires: perl(Bio::Tools::Run::Alignment::TCoffee)
>           Requires: perl(Bio::Tools::Run::Phylo::Molphy::ProtML)
>           Requires: perl(Bio::Phylo::Matrices)
>           Requires: perl(Gtk)
> My manager, while discussing it, noted that we only have a package for
> Gtk2, not Gtk.

Not sure why Gtk is popping up here, maybe Graphviz? 

> Are there some options when I run perl Build.PL to tell it that the Ace is
> optional, and any of the rest is? And neither of us is sure what
> perl(enum) is... though searching cpan, I see there is such a module, but
> no package from our standard repositories.

You can simply remove the lines for those modules in the Build.PL file.  

> May I ask just what the "standard cpan testors" are running on? As I said,
> when I tried, again, weeks ago, it failed to build.
>       mark

CPAN testers are running a standard CPAN installation (using one of the various CPAN command-line clients).


More information about the Bioperl-l mailing list