[Bioperl-l] Bioperl problem

Jun Yin jun.yin at ucd.ie
Mon Jan 24 22:14:30 UTC 2011


I haven't run the code, but I spotted a few problems in the code.

Yusheng, can you try to set the environment as

BEGIN { $ENV{CLUSTALDIR} = "c:/work/ClustalW2 "};
Instead of 
BEGIN { $ENV{CLUSTALDIR} = "c:/work/ClustalW2/clustalw2.exe"};

If that still doesn't work, try to rename your clustalw2.exe into clustalw
as well.

Or, you can run your clustalw2 using system command, and read  in the
alignment using Bio::AlignIO.

Jun Yin
Ph.D. student in U.C.D.

Bioinformatics Laboratory
Conway Institute
University College Dublin

-----Original Message-----
From: bioperl-l-bounces at lists.open-bio.org
[mailto:bioperl-l-bounces at lists.open-bio.org] On Behalf Of Chris Fields
Sent: Monday, January 24, 2011 6:30 PM
To: hanbobio
Cc: bioperl-l at lists.open-bio.org
Subject: Re: [Bioperl-l] Bioperl problem

It's possible this is being caused by UNIX-specific issues with the method
call (note the output redirection).  The problem is, I can't debug this
myself w/o a Windows box to work off of.  Anyone Windows-savvy who can help?


On Jan 22, 2011, at 4:28 AM, hanbobio wrote:

> Hi,all
>  When I run the Bioperl script on Windows XP, there are some problem.
> I think the cause relate to the Bioperl tools. But I don't know how to
dissove the problem.
>  So I come here forhelp.
> The problem is as the attached file
> I had download the ClustalW2.exe, and the program is on
C:/work/ClustalW2/clustalw2.exe. And the program worked when I used it
directly. But it didn't work when I run the perl script(the attached
file:test-new.pl). And I had installed the Bio-Run in the perl package
> Operation system: windows XP
> Bioperl version: 1.6.0
>  Best regards!
> yusheng liao<BioPerl
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

Bioperl-l mailing list
Bioperl-l at lists.open-bio.org

More information about the Bioperl-l mailing list