[BioSQL-l] BIOSQL on Oracle needs an Oracle Patch

Gerben Menschaert Gerben.Menschaert at UGent.be
Mon Apr 24 09:43:12 EDT 2006


Just for you information...

If you're installing BIOSQL on Oracle on Linux AS 2.1, you need to
install the Oracle patch 3612581 (can be found on
http://metalink.oracle.com). If not you will run into the following error,
while testing the bioperl-db installation:

------------- EXCEPTION: Bio::Root::Exception -------------
MSG: error while executing statement in
Bio::DB::BioSQL::PrimarySeqAdaptor::find_by_unique_key: ORA-00600: internal
error code, arguments: [kpofdr-long], [], [], [], [], [], [], [] (DBD ERROR:
error possibly near <*> indicator at char 138 in 'SELECT bioentry.oid,
bioentry.name, bioentry.identifier, bioentry.accession,
bioentry.description, bioentry.version, bioentry.db_oid FROM <*>bioentry
WHERE db_oid = :p1 AND accession = :p2')
STACK: Error::throw
STACK: Bio::Root::Root::throw /src/bioperl/bioperl-live/Bio/Root/Root.pm:328
STACK: Bio::DB::BioSQL::BasePersistenceAdaptor::_find_by_unique_key
STACK: Bio::DB::BioSQL::BasePersistenceAdaptor::find_by_unique_key
STACK: t/03simpleseq.t:88
t/03simpleseq.....FAILED tests 29-59

        Failed 31/59 tests, 47.46% okay

If the patch is installed all tests are successful.

I'm running perl v.5.8.0, Bioperl version 1.5.1 from CVS HEAD, Bioperl-db
CVS HEAD, working on Biosql installed on Oracle on Linux 2.1. AS.

Gerben Menschaert

More information about the BioSQL-l mailing list