[Bioperl-l] StandAlone BLAST on Windows???

Bornman, Daniel M bornmand at BATTELLE.ORG
Fri Apr 21 13:52:07 EDT 2006

All that you have asked about is in place.

1) My PATH variable is set to 'C:\BLASTDB\bin\'

2) the 'ncbi.ini' file is in the C:\WINDOWS directory
The contents of this file are:


3) I formatted the ecoli.nt database with the following command in the
DOS prompt...

formatdb -i ecoli.nt -p F -o T

...this generated 7 files in the C:\BLASTDB\data\ directory.
(I can generate a Blast output with the following command..."blastall -p
blastn -d ecoli.nt -i test.txt -o test.out")

4) I also tried running the script after commenting out the
"$ENV{BLASTDIR} = 'C:\\BLASTDB\\data';" section



-----Original Message-----
From: Chris Fields [mailto:cjfields at uiuc.edu] 
Sent: Friday, April 21, 2006 1:16 PM
To: Bornman, Daniel M; bioperl-l at lists.open-bio.org
Subject: RE: [Bioperl-l] StandAlone BLAST on Windows???

Do you have the database formatted and are your env variables set
correctly in the ncbi.ini file?  From this output,

[NULL_Caption] WARNING: testquery: Unable to open ecoli.nt.nin

it looks like blastall couldn't find the properly formatted database
(env variable not set correctly) or that the database doesn't exist
(need to format using formatdb).  If I remember correctly, the directory
containing your data in your ncbi.ini file (I placed mine in the
C:\Windows dir) should look something like this:


You might also want to try leaving out the BLASTDIR if it is already set
in ncbi.ini.  If you can't get it working I'll look into it (unless
Torsten has WinXP????). 

Christopher Fields
Postdoctoral Researcher - Switzer Lab
Dept. of Biochemistry
University of Illinois Urbana-Champaign 

> -----Original Message-----
> From: bioperl-l-bounces at lists.open-bio.org [mailto:bioperl-l- 
> bounces at lists.open-bio.org] On Behalf Of Bornman, Daniel M
> Sent: Friday, April 21, 2006 11:50 AM
> To: bioperl-l at lists.open-bio.org
> Subject: [Bioperl-l] StandAlone BLAST on Windows???
> Dear BioPerl Listers,
> Does anyone know if the BioPerl StandAloneBlast module works on
> I have a very simple script that will not work correctly.
> My PATH is set to 'C:\BLASTDB\bin'
> My database, 'ecoli.nt' is in 'C:\BLASTDB\data' directory
> Here is the script:
> ## START ##
> $ENV{BLASTDIR} = 'C:\\BLASTDB\\data';
> }
> use strict;
> use Bio::Seq;
> use Bio::Tools::Run::StandAloneBlast;
> my @params = (program  => 'blastn', database => 'ecoli.nt'); my 
> $blast_obj = Bio::Tools::Run::StandAloneBlast->new(@params);
> my $seq_obj = Bio::Seq->new(-id  =>"testquery", -seq 
> my $report_obj = $blast_obj->blastall($seq_obj); my $result_obj = 
> $report_obj->next_result; print $result_obj->num_hits;
> ## END ##
> Here is the error message I get:
> [NULL_Caption] WARNING: testquery: Unable to open ecoli.nt.nin
> ------------- EXCEPTION  -------------
> MSG: blastall call crashed: 256 C:\BLASTDB\bin\blastall.exe -p  blastn

> -d  "\ecoli.nt"  -i  C:\DOCUME~1\Home\LOCALS~1\Temp\QZwYdo9eKx  -o 
> C:\DOCUME~1\Home\LOCALS~1\Temp\ADP2OcZw8z
> STACK Bio::Tools::Run::StandAloneBlast::_runblast
> C:/Perl/site/lib/Bio/Tools/Run/StandAloneBlast.pm:732
> STACK Bio::Tools::Run::StandAloneBlast::_generic_local_blast
> C:/Perl/site/lib/Bio/Tools/Run/StandAloneBlast.pm:680
> STACK Bio::Tools::Run::StandAloneBlast::blastall
> C:/Perl/site/lib/Bio/Tools/Run/StandAloneBlast.pm:536
> STACK toplevel localblast.pl:12
> --------------------------------------
> Thank You,
> Daniel Bornman
> Researcher
> Battelle Memorial Institute
> 505 King Ave
> Columbus, OH 43201
> 614.424.3229
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

More information about the Bioperl-l mailing list