[Bioperl-l] Re: UniGene modules and Bio::Cluster

Jason Stajich jason@cgt.mc.duke.edu
Sun, 5 May 2002 23:36:48 -0400 (EDT)


I prolly should have named that method each_node()
to go with Ewan's naming convention in most other objects.

The convention should be:

next_XXX - an iterator method

each_XXX - returns a whole array/hash.


-j
On Sun, 5 May 2002, Allen Day wrote:

> Andrew,
>
> > >I'd like a next_component() method that can be
> > Can you show  me how that would be done? Are there examples of similar
> > things elsewhere in bioperl?
>
> Looks like Bio::Tree does something similar to my proposed components()
> method.  For next_component() you could iterate over the (sorted?) hash
> that components() returns.
>
> =head2 get_nodes
>
>  Title   : get_nodes
>  Usage   : my @nodes = $tree->get_nodes()
>  Function: Return list of Tree::NodeI objects
>  Returns : array of Tree::NodeI objects
>  Args    : (named values) hash with one value
>            order => 'b|breadth' first order or 'd|depth' first order
>
> Maybe it would be better to inherit from and extend the functionality the
> Bio::Tree classes than reimplementing.
>
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l@bioperl.org
> http://bioperl.org/mailman/listinfo/bioperl-l
>

-- 
Jason Stajich
Duke University
jason at cgt.mc.duke.edu